Jump to content
Sign in to follow this  
Potash123

Condor Drive ?

Recommended Posts

Engine is absolutely fine, cutting section engages fine, but the hydraulic drive will not engage and there are many  bubbles coming up into the reservoir, Help please. Thanks. 

Share this post


Link to post
Share on other sites

Is the machine new to you? If so are you aware that the hydro drive will probably have a by-pass or dump valve to allow the machine to be moved without the engine running? If that is open the machine wont move. If it is closed there is the possibility that the pump has entrapped air and needs to be bled.    . 

Share this post


Link to post
Share on other sites
On 8/29/2018 at 4:30 PM, Potash123 said:

Unable to find valve has anyone got any pictures please or any other tip-drawings etc, where is the pump etc. Honda powered, thanks.

The issue is dating your machine. if the Honda is original equipment the machine is "relatively" recent . Most of the Condors that I had anything to do with had Kohlers.

If you Google Hayter Condor Hydrostat there is plenty of information. The problem is matching it to your machine.

A few images of the hydrostat may help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...