Jump to content
Sign in to follow this  
4x4forks

Poor Starting. Give up and start again

Recommended Posts

The Kubota B6100 Story go's on. The three cylinder D650 engine has had a few issues in this tractor but once it gets running it was fine and had loads of power. Howevery starting has been an issue loads of smoke and loads of heat plugs. I overhauled the diesel  injectors and this had no improvement. I relented and purchased a diesel compression tester. At very best i was getting around 220psi on the best cylinder. The book states it should be up around 400 to 460 psi. OPPS !! 

After researching  the costs I could purchase the parts from ether Kubota or a chines copy company. I was advised to go genuine. 

I turns out that I have a very early engine 000236. As the bits are on order the clean up begins. 

I am going to have new liners pressed in and all new bearings ,seals and gaskets.

Will update as the build go's on

45890754_2032671940113113_7753546529226358784_n.jpg

45863729_255486451791364_5684269511222493184_n.jpg

45864694_512357219281855_254599674122469376_n.jpg

45866268_1770641093064371_1808425443456450560_n.jpg

46093491_251959748822464_3272672449992327168_n.jpg

43331153_504323876637793_1048991503726149632_n.jpg

Share this post


Link to post
Share on other sites

After tea I opted to drop the rad on and give it another run . With a few more revs and heat in the engine she ran up clean and smooth. I will see what its like cold in the morning and refit the front axle.:england:

Share this post


Link to post
Share on other sites

Well she drives again. It Appears I have a poor injector. Number one is smoke on start up but clears after a short time . Going to get them properly checked and overhauled but it will run and starts loads better than it did.

46121207_508701519630693_3949414482429607936_n.jpg

46276237_265449184115566_5657684067387179008_n.jpg

46237064_2239673749597415_6292006181015650304_n.jpg

Share this post


Link to post
Share on other sites

After a bit of running It still smokes badly on cylinder one. on start up also dosn,t sound as it is running on all three until it starts to warm up then all is fine . I have removed the injectors and had them tested today . I have replaced all three injector needles with items new from ebay. On testing all the  spray pattens on the injectors  are appalling . so New genuine needles on order and set up. Hope this will make things a bit less smokey.  :banghead: 

Share this post


Link to post
Share on other sites

WHAT A DIFFERENCE!!!!!! Picked up my injectors after being overhauled with genuine  Nozzles. less than 24hrs from drop off to collection Fantastic service. Fitted , bleed and fired up first time . No smoke and runs like a new engine .  

It runs smoother and cooler now . I think washing out the block helped.  Having a temp gauge now gives faith in what is happening. I will in time fit an oil pressure gauge. Now need a few fields to plough to bed it all in.

46322112_570373300068004_8660475199294013440_n.jpg

46445863_1886582411437231_7653222840585420800_n.jpg

46383079_353557868553607_5854299496875294720_n.jpg

Share this post


Link to post
Share on other sites

Note to self Do a job properly! Found a damp patch under the tractor this morning. It could only be coming from one place. The core plug behind the flywheel. Up Side is I have got this splitting the tractor in half down to a quick job now.:wacko:

46407330_712911682421317_1987914291419807744_n.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×